Phone800.366.3472 SupportGet Support DocumentationDocumentation Resource CenterResource Center
search
close
Open Menu

Requirements for previous version: 10.1

This page includes requirements and other important information about Synergy/DE 10.3.3. Refer to the Quick Migration Guide (PDF) for more information about upgrading.

Product Keys

If you are upgrading to version 10.3.3 from 9.5.3 or earlier, you will need new product keys. You can obtain keys either from the Licenses site or by emailing your registration information to Customer Service.

To email your registration information…

On Windows, using the Synergy Configuration program,

  1. From the Licensing tab, click the Print Registration Information button.
  2. Complete the fields and click the Save to File button.
  3. Send us the file.

On Unix, send the register.lm file located in the synergyde/lm directory.

(See “Configuring License Manager” in the Synergy/DE documentation for additional information about obtaining product keys.)

Runtime Compatibility (Compilation Requirements)

We recommend that you rebuild your Synergy applications with 10.3.3 to benefit from all the new features and fixes. If you choose not to rebuild, your application should still work fine with the 10.3.3 runtime, with the following exceptions:

ISAM File Compatibility

We recommend that you convert your REV2 and 3 files to REV4 or higher. This will improve performance and ensure future compatibility. Synergy/DE 10.3.3 can access REV2 and 3 files but cannot create them; by default it creates REV6 and can also create REV4. In addition, isutl does not support pre-REV4 files (other than to convert them). REV4 files can be accessed by Synergy versions back to 7.1. REV6 files can be access with Synergy/DE 10.1 and higher. See the Quick Migration Guide (PDF) for more information.

Server Compatibility

We recommend that you update all Synergy/DE products to version 10.3.3. If you choose to update your server(s) only, refer to the table below for the minimum client versions supported with Synergy/DE 10.3.3 servers.

For SQL OpenNet, the server version must be equal to the client version. For other Synergy/DE client/server products, the server version must be equal to or higher than the client.

10.3.3 server productSupported client version
xfServerSynergy/DE 6.1 and higher
(9.3 or higher clients are required for encryption support, 9.5 or higher to use the Select class, and 10.3.1 or higher for connection recovery.)
xfServerPlusxfNetLink 7.1 and higher
(For encryption support, 9.3 or higher clients are required for xfNetLink .NET and xfNetLink Synergy and 9.5.1a or higher for xfNetLink Java.)
SQL OpenNetxfODBC or SQL Connection 10.3.3
License Manager(Windows) Synergy/DE 6.3 and higher
(UNIX) Synergy/DE 6.1 and higher

 

RDBMS Support (with SQL Connection)

SQL Connection 10.3.3 supports the following databases:

In addition, fee-based support from our Professional Services Group is available for the following databases:

Third-Party Products

Synergy/DE interfaces or integrates with a number of third-party products. Synergex supports these interfaces and integration points but does not support the third-party products themselves. We strongly encourage you to maintain support contracts for any third-party products that are important to your applications. The table below specifies the versions of third-party products that we expect to work successfully with Synergy/DE. In most cases, higher versions than those listed will also work.

An asterisk* in the version column indicates a new minimum version requirement.

Third-party productVersion with which Synergy/DE 10.3.3 is expected to workNotes
HP SSL*1.4, SSL1 1.0-2c(OpenVMS) 1.4 is based on OpenSSL 0.9.8x; SSL1 1.0-2c is based on OpenSSL 1.0.2c. Synergy/DE installs the libraries compatible with the SSL version your OS version supports. See “OpenSSL requirements” in the Synergy/DE documentation. Connectivity Series requires SSL1 1.0-2c.
HTTP1.0For use with the HTTP document transport API.
Internet Explorer9, 10, 11For accessing Synergy logic from xfNetLink .NET and xfNetLink Java.
Java Virtual Machine (JVM)1.5, 1.6, 1.7, 1.8For xfNetLink Java, which requires a JVM that is compatible with JDK version 1.5 or higher.
JavaServer Pages1.1 and higherFor use with xfNetLink Java.
Microsoft .NET Framework4.0, 4.5.x, 4.6Version 4.0 or higher is required for installation and for most Synergy/DE products that use the .NET Framework. Device licensing requires version 4.5 or higher.
Microsoft Visual Studio2012 Update 4, 2013 Update 4, 2015 Update 2, 2017For use with Synergy DBL Integration and xfNetLink .NET. Synergy/DE SDI 10.3.3e and higher requires Visual Studio 2015 Update 2 or higher. Developers using Visual Studio 2017 should stay current with future VS and SDI updates.
MySQL5.1For use with SQL Connection.
OpenSSL1.0.xFor use with the HTTP document transport API, data encryption, and xfServer and xfServerPlus client/server encryption, and Connectivity Series data packet encryption. See also “OpenSSL requirements” in the Synergy/DE documentation and Synergex KnowledgeBase article 100001979.
Oracle10.x and higherFor use with SQL Connection.
SQL Server (Microsoft)2008 R2 (with SP 3) and higherFor use with SQL Connection. Synergy/DE 10.3.3f supports Microsoft ODBC Driver 17 for SQL Server (required for Azure Managed Instance support). With Synergy/DE 10.3.3a and higher, Microsoft ODBC Driver 13 for SQL Server is supported (and is the default when you use VTX12_SQLNATIVE); Microsoft ODBC Driver 11 for SQL Server is also supported. For Synergy/DE 10.3.1 through 10.3.3, “Microsoft ODBC Driver 11 for SQL Server” is the only supported driver (and is the default when you use VTX12_SQLNATIVE).
Terminal emulatorAt least limited VT100 terminal compatibilityFor use with the remote debugging feature.